Maintenance on Nets Easy Portal - CHG0368298

Scheduled for Jul 7, 22:00 CEST  -  Jul 8, 01:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 30, 2025 - 11:10 CEST

Scheduled

During the maintenance window the login to our merchant portal will be unavailable for a brief period.
Posted Jun 18, 2025 - 10:00 CEST
This scheduled maintenance affects: Nets Easy Merchant Portal.