Disturbance on Nets Easy - INC0889567

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 13:08 CET

Identified

The issue doesnt impact live transactions
Posted Mar 04, 2026 - 10:38 CET

Investigating

Our system indicates an issue with Klarna transactions
Posted Mar 04, 2026 - 09:34 CET
This incident affected: Nets Easy Checkout.