Issues with Paypal transactions - INC0722721

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 15:15 CET

Investigating

We are currently investigating an issue with Paypal transactions.
Posted Feb 18, 2025 - 13:27 CET
This incident affected: Nets Easy Checkout and Nets Easy API.