Disturbance on 3DS transactions - INC0627146
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted May 29, 2024 - 15:26 CEST
Investigating
We currently investigating issue that might cause a 3DS transaction to fail.
Posted May 29, 2024 - 12:56 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.