Login issue on Nets Easy Portal - INC0640353

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Jul 02, 2024 - 07:34 CEST

Investigating

We are currently investigating this issue.
Posted Jul 02, 2024 - 07:12 CEST
This incident affected: Nets Easy Merchant Portal.