Disruption in card processing - INC0792413

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Jul 20, 2025 - 00:38 CEST

Identified

We are currently experiencing issues with transaction processing due to a disruption in card services at NETS.
Posted Jul 19, 2025 - 19:07 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.